Security Alerts
Security updates for Microsoft 365 apps on Windows 7 ending in January 2023
After January 10, 2023, Microsoft 365 Apps running on Windows 7, Windows 8.1, or Windows Server 2008 R2 will stop receiving security updates.

Security Alert: Microsoft Support Diagnostic Tool Vulnerability
On Monday May 30, 2022, Microsoft issued CVE-2022-30190 regarding the Microsoft Support Diagnostic Tool (MSDT) in Windows vulnerability.

Security Alert: Critical VMWare vulnerabilities
On 18 May 2022 VMware published a Security Advisory to address vulnerabilities in multiple products .

Irritation: Cyber Crime’s new superpower?
Annoyance is the latest tactic in the E-Crime playbook: Attackers are using a technique called “Prompt-Bombing”

Security Alert: APC UPS vulnerability
Schneider Electric has announced that vulnerabilities associated with APC Smart-UPS uninterruptable power supply devices which, if compromised, may allow for potential unauthorized access and control of the device.

Security Alert: Ottawa warns Canadian businesses of increased threat of Russian cyberattacks
The federal government is warning Canadian businesses and organizations about the increased threat of cyberattacks and malicious software amid Russia’s invasion of Ukraine.

Security Alert: FBI warns scammers using video meeting links to compromise accounts
The FBI warns that scammers have ramped up video meetings as a tool to trick unsuspecting victims into handing over their money.

End of Life: Blackberry devices
The legacy services for BlackBerry 7.1 OS and earlier, BlackBerry 10 software, BlackBerry PlayBook OS 2.1 and earlier versions, will no longer be available after January 4, 2022.

Security Alert: Microsoft Exchange Server Vulnerability
Microsoft warns admins to immediately patch a high severity vulnerability impacting Exchange Server 2016 and 2019.

Security Alert: Apple iOS Vulnerability
A Security Advisory has been issued for Apple iOS

Google Chrome Vulnerabilties
Multiple vulnerabilities have been discovered in Google Chrome

Security Vulnerability Alert: HP Laserjet Products
It is recommended that you update your printer software.

  • 1
  • 2

Please help us improve our website by providing your feedback

Please help us improve our website by providing your feedback